Public Test Realm Appearing


Ummm, now what?

Its opening a website page not a game yet. So you probably need to set default browser.


Installation worked fine for me but the servers aren’t up yet so the Play button just goes to the news post.

1 Like

I still don’t have the PTR in my library, I got my game gifted to me from a friend, would that be my issue?

I have the PTR now but it isn’t a client. It’s just a redirect link… o.O A 15kb size download!


you do realize you just installted 2kb of data right? clearly the PTR isn’t in that download


It seems like some may be seeing their Alpha client getting updated. Most of us, including myself, were never in it.

I had to restart steam and have it update and etc before the PTR showed up in my library. If that helps anyone!

1 Like

I did as well, but I have the PTR. try rebooting Steam


Just tried to exit steam and logging back in, it’s now in the library! For anyone else having the same issues, try logging out and back in.

1 Like



1 Like

It popped up in my library just now. As a ~2Kb download and when you click play it hyperlinks to the PTR website. Seems to be the standard maybe until 3:00PM?

1 Like

Relogging didn’t fix anything, no download for main application still.

Did you exit steam completely?

No download, exited steam completely 2 times

Yes, twice.

If exiting/relogging doesn’t work, try restarting your whole PC.

It appeared for me seconds ago without having to relog via steam.

just turned my pc on, there is nothing, nothing in steam library and nothing on steam store itself to search for the ptr