Pulled item from trader and did not go into my inventory

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: NittyGritty1
  • What server/world did you experience your issue on:OhoNoo
  • Describe the issue you are experiencing: I have an item on the trader for sale and I wanted to take it down to keep it. When I removed the item from the trader it did not go into my inventory or bank, it is now listed under my completed transaction section. I did not receive payment for the item and it is not in my possession.
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: I am out a valuable item.
  • (if a bug) Were you able to recover from the issue: No
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: I tried to restart the game and relog twice.

Did you check the storage shed of where you listed the item?

I did yes. it is not there the only place I can see it is in the completed transaction section of the trader.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.