Race for the box bugged

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: Cara Carmina
  • What server/world did you experience your issue on: Olympus
  • Describe the issue you are experiencing: The quest for level 4 azoth staff is not showing up
  • Is this a bug? (If this is an exploit, please dm Aenwyn or Luxendra) bug
  • (if a bug) How did the issue effect your gameplay: I can not get the level 4 azoth staff
  • (if a bug) Were you able to recover from the issue: no
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: I logged off then on again and nothing. Ive ran Into the depths again to see if the quest was available but nothing.
  • When did this happen? (Date and Relative time; please include your timezone) 9/22/2020 between the hrs or about 10 pm to 1230 am

uhhh yeah im a dumb ass. I dont think this quest is bugged I just havent unlocked it yet. I thought it would show up right after I finished Into the Depths but it looks like its a few quest after that. I’ll do the quest and then check.

EDIT: I got. sorry for the post

No problem at all! Glad to hear this is solved.

1 Like