Reaper's Locus Quest - Alectos not dropping Locus

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: Wyld Wyld
  • What server/world did you experience your issue on: Maramma
  • Describe the issue you are experiencing: Reaper’s Locus (Expedition) Quest - Alectos the Relentless not dropping the reaper to complete the quest. We had multiple group members with the quest and the Alectos did not drop anything to complete the quest. We had one member run multiple Starstone Expeditions and it did not drop.
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: Unable to complete a quest.
  • (if a bug) Were you able to recover from the issue: no
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:
1 Like

Hey forHIM, the developers are currently aware of the problem regarding Alectos and the reaper’s locus quest. I’m sorry to see it occur to you as well though and understand how frustrating it can be when something stops you from progressing. :confused:

i got the same problem i try it 5 times and not found te item that i need

I cannot loot the Locus either, please fix.

i got same problem i can not complete my quest now feels bad

it’s been nearly 6 weeks and not fixed? this can’t be right can it? There’s another post about this as well.

Also having the same issue, hopefully we get a fix soon!

Hey @Centeotl, If the dev’s are aware and you do understand the frustration how can this quest still be broken 20 days later?

Ohh on a side note I just tried to complete Reprieve for Restless shore but Inn keeper Laszlo Tomaso has no dialog to speak to him to finish the quest. Wonder how long this one has been broken too.

Same, quest is still bugged after a few runs.

I’m having the same problem for a few days now… please fix it! :weary: :pray:

Suskas - SA / Apsu

Any predictions to fix the error?

Same here, can’t complete

Lillypaws Greyzone Orluk

Hey everyone, I’m so sorry for the late reply!

Please provide your character names and servers, so our customer support can manually help you out with this quest.

1 Like

Suskas - SA / Apsu

Thank you, Suskas!

1 Like

Desorath Gonthor /Orun
Attempted multiple times to no avail.
Attempted to reset quest multiple time to no avail.
Have not been able to complete this quest since I got it 20 some odd levels ago.

Having the same problem. Have run Startsone multiple times but there is no drop. Have also tried resetting the mission, but still nothing.
Character Name: Deecey
Server: Utopia

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.