Rend not applying

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: Daayou
  • What server/world did you experience your issue on: El Dorado
  • Describe the issue you are experiencing: Rend not applying on Chardis
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Wiped.
  • (if a bug) Were you able to recover from the issue: Yeah, but odd.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:

We wiped on Chardia - normal. This is very odd as it has not happened before. We didn’t notice what was happening. Then when we tried again, I noticed the bar for Chardis was missing buffs. I hit shockwave. There was NO rends applied to Chardis at all. I thought this may be a temporary bug. We let all buffs fall off of Chardis, then did it again. NOTHING.

The composition was:

SnS with Warhammer.
Warhammer with Great Axe
Warhammer with Great Axe
Warhammer with VG
Lifestaff with VG.

We rotated oblivion to make sure that it was up as much as possible.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.