Runic leather failed attempt x3. 24 Hour cooldown wasted

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Detoxz

  • What server/world did you experience your issue on: US-E Macaria

  • Describe the issue you are experiencing: Crafting attempt failed results in a Timer Cooldown for the end game materials.

  • Is this a bug or an exploit: BUG

  • (if a bug) How did the issue effect your gameplay: Resulted me in losing out a 3rd time trying to be able to craft materials.

  • (if a bug) Were you able to recover from the issue: NO

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: Attempt crafting. Happens sometimes, sometimes no issues. It’s spontaneous.

1 Like

I have had this same issue on US West - Yrrgdrasil. Tried to craft Runic Leather. Says crafting failed, doesn’t use resources, but puts leather on 24 cooldown. Such a waste of time!

reloging should fix your cooldown

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.