Sea Dreams quest bug

Hello

I cant complete Sea Dreams quest, after when i came into area of mission it doesnt update.

In this video, when this player came near this area, it automatically change its mission to kill 3 losts.

Here pics of mine problem:


As You can see i’m in area and nothing happen.

BR

31 Likes

Same here. The area does not update. There is only once chest. Please fix this!

5 Likes

Same here!
I noticed that when you come from another area, it does not warn you that you entered Haunted Isle Southbeach area, so when I caught the chest I didn’t get the Billiam’s Astrolabe and didn’t complete the Quest!

2 Likes

Noticed this too tonight while me and one more was questing, for some reason there is no “area” for this quest for it to update, not sure where It has gone but I’ve tried to trigger it by heading there and relog before taking the chest but still nothing. Think we got to wait for a fix for it before it can be completed.

@Luxendra, any chance you can make the team aware of this/looking into it?

I am experiencing the same issue on this quest. cant complete it. And the shrine is missing.

2 Likes

same

Same. After looting the chest nothing happens

Same for me…

It doesnt happen on chest loot… It is supposed to trigger the quest steps once you enter the area landmark, but that is not triggering, thus not allowing quest advancement.

1 Like

@Kay Pssst… Over here. Some things are missing…

Same problem!

I’m having the same bug, can’t complete this quest at all, I abandoned and took the mission twice, the result was the same.

Same issue, like the post so it gets some more attention

Same here. Can’t complete the quest. Please fix it. Thanks :slight_smile:

have the same issue

Same issue.

Same problem…pls fix

cant complete quest. tried abandoning and re-accepting quest no fix. tried fast travelling no fix. noted that the quest seems to lag when you “unpin” or “pin” the quest and doesn’t seem to register until pull up the map again.

Same issue here

Quest bugged for me to

1 Like