Server bug. Cannot log in. Character selection does not show up

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Hymiti

  • What server/world did you experience your issue on Calnogor

  • Describe the issue you are experiencing: Cannot log in. The world list does not show up. Cant even select a character

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: I can’t even play the game

  • (if a bug) Were you able to recover from the issue: No

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: Just cant log in

5 Likes

@Firus

Same thing is happening to me. I have 2 characters in US East. One on Takamagahara and a second on Maharloka. At the character select screen I get this:

Me too.
Character: Yaourt, server/world : on Bilskirnir US/East
'N yeah that’s a bug so I can’t play the game

that’s mine character select screen

Amazon has issues with US East servers:

can’t switch to another region either. tried to check US West and it won’t switch regions.

Same on EU Server

I believe I have this same issue. The game launches but when it gets to the Character select screen it never loads my character nor any servers.

  • What is your character name in New World: Sikpack
  • What server/world did you experience your issue on: All, but I play on Nidavellir
  • Describe the issue you are experiencing: Cannot log in. The world list does not show up. Cant even select a character
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: I can’t even play the game
  • (if a bug) Were you able to recover from the issue: No
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

I should note that this starting happening last Monday (12/20), just after the servers merged.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.