Server Transfer Bug: Can't Transfer anywhere

Hello Guys,
so I tried to transfer from Aaru to Tartarus.
Didnt have a Transfer Token left, so I bought one.
When I tried to transfer servers I got this message: “unexpectedly lost contact to game server, please try again later.”
This problem keeps occuring since then and I can’t do anything about it.
I tried all the basic troubleshooting and I contacted AGS Support.
Litterally didnt do anything besides wanting me to send my Crash Reports and not doing anything afterwards.
Anyone had the same problem and actually got it fixed?
Found 1-2 posts in the Forum, but seemed like there is no fix to it.
ty in advance

servers are down, try again later

1 Like

Im trying for 5 days straight. And I tried transfering to other servers aswell. So no, servers down isnt the reason.

Have you tried starting the transfer from a shrine, rather than a city? I know that fixed some issues in the past.

1 Like

Hello @Lowwww,

Welcome to the New World forum, I’m really glad to see you are here at the forums and hope you can enjoy your time here and at the game as well!

I’m sorry about the issue you’re having with tre server transfer, I can advice you to follow the @JakeL’s comment and if this doesn’t work, then I can recommend you to reach us via player support using the following link: Contact Us | Amazon Games to create a support ticket and review your case in more depth.

Please make sure to add the DxDiag and Gamelogs through a sharing link from a Cloud Storage like Google Drive to the support report, you can pull it following this steps:

DxDiag report:

  • Go to Windows Start search bar and type dxdiag.
  • Click on dxdiag.exe.
  • When green progress bar goes away, select Save All Information and save the file to their desktop.

GameLogs:

  • Game logs can be found on: \Users\USERNAME\AppData\Local\AGS\New World\CrashDB\reports\

If you need further assistance in any other issue please don’t hesitate in reaching us again!

Cheers!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.