Server Transfer: Character_Persist_Failure

Also experiencing this issue after server transferring. I am unable to trade, trading post, collect items, stash items. If my inventory changes I get a “Character_Persist_Failure” error and get disconnected from the server.

New World Support Ticket: Contact Us | Amazon Games

Best advice would be to create a ticket if it’s important you see this fixed now, otherwise waiting it probably your best bet. Don’t try to make any changes to your character in the mean time since they are likely to revert back and it could put your character in a worse state.

I’m having this same issue.

I am having the exact same issue. This is incredibly disappointing, right as I though I get to play with my friends.

  • What is your character name in New World: Vidrak
  • What server/world did you experience your issue on: Bouneima (moved from Maldonada)
  • Describe the issue you are experiencing: Character_Persist_failure
  • Is this a bug or an exploit: Game Breaking Bug - Completely Unplayable
  • (if a bug) How did the issue effect your gameplay: Impossible to play the game
  • (if a bug) Were you able to recover from the issue: No
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

What are the steps to reproduce the issue as you experienced:

  • Removed all of my buy/sell orders, and was kicked from my company on Maldonada, so was good there. Spent all of my faction tokens.
  • Used the free server transfer coin to move my character to the Bouneima to finally play with my friends.
  • It sat and spun for a while (a minute or so?), then kicked me to character select.
  • I then see my character select, and shows the new server I moved to.
  • Click play, load in and I cannot interact meaningfully with the world at all.
  • I can run around some and tried crafting, I even ran all the way to a town to unload my inventory. Dropped off a bunch of items and logged out.
  • Log back in to my character being reset back to the exact same spot I was on Maldonada.
  • I will get the error above when trying to meaningfully interact with the world, like trading or using the auction house.
  • I have tried your “fix” from another post with resetting DNS, and about to try a VPN, but so far, still getting the same error and character reset. I basically can’t do anyhting.

Some other notes, I had nearly 100 buy orders on Maldonada when I transferred. I believe I removed them all and double checked. I transferred almost immediately after. I don’t know if there was any kind of desync there.

It basically appears like I am stuck in limbo on the player-to-player interactions, and can’t progress at all. But when I load back in, seems to keep pulling the information from my new server and resetting me.

I am an alpha player, and this is pretty frustrating, but understandable. Please contact me directly if you would like me to try anything. I want to get back in game!

Thanks!

I am having the exact same issue. My company transferred to a higher pop server as well so having queue times (which generally I don’t care if I have to wait for 30 mins to get in - not the issue on its own) is only making this all that much more frustrating. Please make this a top priority to resolve, many of us have hundreds of hours on these characters!

Hey there everyone,

Our team is aware of the issue and they are actively investigating it now. When I have more information, I’ll be sure to share it!

Hang tight!

12 Likes

Thank you TrevzorFTW.
My information in game.

Character name: OG Recipe KFC
Original Server: Laputa
Destination Server: Lagado

Thank you !

Thank you TrevzorFTW.
My information in-game.

Character name: Ambient
Previous Server: Theleme
Destination Server: Taenarum

Thank you !

Thank you TrevzorFTW.
My information in game.

Character name: SolaceForsaken
Original Server: Tritonis
Destination Server: Eden

Thank you !

i have the same issue! every time i get disconnected, when i log back in all the progress i did after the transfer rolled back! all progress gone! back to where i was and how i was when i 1st stepped in the new server. hope this gets resolved soon. i am not goina be able to play knowing the progress will just roll back when i get kicked out of the game.

Character name: Aegonjuju
Original server: carabas
Destination: moriai

Thank you TrevzorFTW.
My information in game.

Character name: CJtheGreat
Original Server: Andlang
Destination Server: Elphame

Thank you !

Yea, I literally just lost like 3.5 hours of progress. Unfortunately, I have to just stop playing until I know this is fixed because it is pretty disheartening.

Thank you TrevzorFTW.
My information in game.

Character name: GG Fizz
Original Server: tritonis
Destination Server: Mictlan

Thank you! :sweat_smile:

Thank you TrevzorFTW.
My information in game.

Character name: Henntv
Original Server: Amano Iwato
Destination Server: Himavata

Thank you !

Same thing happening to me. Transferred to server and can’t use Trade post or trade with others. Ran a Dynasty dungeon, relogged, and lost all my progress from there.

Character Name: Buhamut
Old Server: Briedablik
Current Server: Asphodel

Character name: Valakivi
Original Server: Silha
Destination Server: Himinbjorg

i played for a while and my progress didnt save, i cant move or do anything cause im stuck with a lot of items i cant post on the trading post, or store cause my storage is full.
So i CANT PLAY AT ALL

Did any of you happen to server transfer while being over-encumbered? I did. I wonder if that had anything to do with it.

I did too because I literally took everything off the AH with my storage in that town full. I’m wondering if that’s what may be an issue?

I have found a fix buds :slight_smile: got mine working. It is a caching issue :slight_smile:

1 Like

elaborate the fix please