Shivering Timbers is not a level 58 quest anymore

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Graill
  • What server/world did you experience your issue on: Mag Mell
  • Describe the issue you are experiencing: Expedition boss at the end of a level 58 quest
  • Is this a bug or an exploit: Who knows with this dev team
  • (if a bug) How did the issue effect your gameplay: Stopped gameplay for the next week.
  • (if a bug) Were you able to recover from the issue: No, I am still buried in the sand on the beach with a 100 ton cannon up my ass marking my grave.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: The screenshot is pretty gruesome, we do not want to offend anyone.
  • What are the steps to reproduce the issue as you experienced: This is very easy, go to Reek Water, choose the quest “Shivering Timbers” a level 58 quest that was single player. Go through the quest as before and savor what patch 1.1 did to “enhance” this level 58 quest, then, on the last step, look in awe as a level 65 gold elite with 23 million hp greets you instead of the level 60 silver elite, and then proceeds to turn you into a Human popsicle with the cannon as the stick. The reward is a level 58 green garbage ring for all this trouble.
7 Likes

15 hours and no reply AGS? How many people do you have working on bug reporting? Where is the support?

Further consideration? Now I have read it all. Thanks though, you pushed me over the fence on changing my Steam review. Now excuse me while I take my first positive review regarding New World “into consideration”.

No need to reply, it would simply be more patronizing by your “support team”

1 Like

Having felt the pain of meeting that expedition level boss at the end of what was supposedly a quest I could solo, I also wanted to quit. There are at least 3 Reekwater quests where mobs just keep spawning every time someone dies while trying to complete it so you end up with 30+ mobs. When I got to the area, I was super excited to see this wasn’t an issue and started fighting the waves. Got to the boss and he took me out in like 3 hits. My husband came out to try and help and BAM! we’re both dead! Tried MANY different tactics to try and beat him. At one point, we had him down to half hit points and we were so excited…annnnd he retreated. Hundreds of gold in repairs later, we gave up. Reekwater as a whole needs serious attention. @Ligase48

TL;DR = Felt the same way about this boss. STILL feel the same about this boss. Your bug report made me laugh for several minutes. Pretty sure my ears are still ringing from my head being stuck in that cannon!

Ya, a lot of brainless choices being made by the AGS staff as a whole.

Ran into this just of now. And can’t believe it. A lvl 58 Quest. Not marked Elite, Team or something. And the Boss is a lvl 65 Gold Elite. Well… yeah. Nonsense on so many levels.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.