Sold market items are not giving gold

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: dollaBillions

  • What server/world did you experience your issue on: Eden / US East

  • Describe the issue you are experiencing: My market items have sold, but I am not getting gold for them. Showing as active order, with sold quantity = 1.
    To note: The 1 font / type used in the “Qty” category is not the same used in “Sold” category.
    This could be a matching issue.

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: I’m not getting gold for sold items.

  • (if a bug) Were you able to recover from the issue: No.

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced:
    I simply see many items with 1 sold as the quantity that are single items I posted. They’re stuck as active orders.
    To note:
    I did test putting one up and having someone buy it. It sold properly.
    I also tested putting up for sale, logging out and having them buy it. It sold properly.
    HOWEVER, the items I posted before reset are still stuck as active orders that have a sold quantity of 1.

Just a heads up this is still a thing. I’m not sure what or why this is, but seems I have maybe 25k gold in completed orders that are not giving me my gold…

Got the same issue:
4 days ago, I put a bag on the trading post for 3000 gold and made it only last 1 day. I just logged in, I don’t have the bag, TP says it was sold but I didn’t get any gold. So frustrating…

think it’s just a visual bug I’m on a dead server and no matter what I post it shows as sold happened ever since trading post change and when my void ingot sold it actually sold. so I’ll rule it as a visual bug

I am having this exact issue, please fix

Naw I just confirmed. Check your completed history and you’ll find things that are also completed that you’re not getting money for

Yeah also check your completed history. You’ll find things that are on there that have sold but you don’t get the money for.

Lastly, I found that there are more active listings that have sold and people have gotten, but they stay as active and you can pull them off the market after.

Pretty sure at this point it’s a new duping bug.

Having the same issues as well, but it seems like game developers don’t really care about players losing money and they just focus on nerfing everything beneficial to players

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.