[SOLVED by MYSELF] [Video Link] Character stuck at revival situation (IMMOBILIZED)

up

This is the conversation with amazon staff. They try to help but i think it wont be solve.

You are now connected to Anthony from Amazon.com.

Me [23:01:21] : Issue: New World - Technical: Something Else

Me [23:01:32] : hello

Anthony [23:01:35] : Hello , my name is Anthony , thanks for contact Amazon Games.

Anthony [23:01:37] : How may i help you today?

Me [23:02:15] : well i spoke with you yesterday about my character problem

Me [23:02:33] : and said by amazon it will be solved in 24 hours

Me [23:02:45] : now even after patch i had still have same problem

Me [23:02:51] : i cannot play game

Me [23:04:04] : Can you check my last conversation with your team yesterday?

Anthony [23:04:23] : Let me check, one moment.

Me [23:13:34] : so? you there?

Anthony [23:14:30] : Yes, i’m still working on it! :slight_smile:

Me [23:15:42] : i should say im really frustrated,pissed off and bored about this situation this is 5. day that i cannot play game

Me [23:18:40] : if dev team uncapable or desperate to solve this problem so please tell me so i can uninstall game from my pc and maybe i can stop wasting my time.

Anthony [23:20:08] : Just a moment, i’m still working on this.

Anthony [23:30:29] : I’m going to submit a ticket about this issue because i was looking for information about the ticket form the previous agent but i don’t see anything about it, so i will do it from my end and i’m going to follow the situation.

Me [23:31:07] : how ?

Me [23:31:20] : just talked a guy yesterday from your team?

Me [23:31:57] : and he said me it will be solved in 24 hour and you will got an e-mail about it

Anthony [23:34:13] : I really understand and i’m sorry for the inconvenience but now i will do the ticket and the follow up.

Me [23:38:38] : i understand its not your fault ofc. But it seems amazon has no any qualification or staff to fix bugs and exploids in game. Seems no hope that you can help me too. I just give up.

I can confirm I get the same error, from what I found out from another post it seems to be an issue either from Outpost Rush/Arena (Like Reekwater/Edengrove) if you die inside and do not finish the Output Rush/Arena your character will be stuck like this permanently.

Apparent fix is to do another Outpost Rush/Arena and finish it and this clears the “Tag” on your character that you are stuck inside and can use the “Give Up” option again.

@ImSp4rky
I achieved this magnicifent bug at lvl 60 gardens dungeon. Not inside any outpost rush/arena. I dunno your solution could save me from my misery :confused:

image

2 Likes

@Iustinus
:smiley: definitely yeah :smiley:
thats make me smile thanks m8

Check the video if you have similar problem. You can leave comment here.

Same issue :worried:

1 Like

Same for me, contacted support and everything I could do, but they don’t even have a game master to unstuck people…

yeah 5th day and still waiting a solution.

1 Like

Character Fudhud

Server aztlan

Dead since Friday night Oct 8th,

Died doing the syndicate scrivener quest line,

no real support to get fixed, just told they are “working in it” patch didn’t fix it I’m still dead… Just get a ton of loading screens for about 5 minutes than my corpse shows up.

Fun game…

Hello world, can someone help us in this development team ?

up

still same. no soluıtion at all.

All right i solved this issue myself and anyone has same problem just read here. This bug happening because of the arena boss Zygoramet.
First of all You need to craft Monoecious Tuning Orb | New World Wiki | Fandom from any stonecutter station(You need min lvl 50 in stonecutting). This item will let you enter the arena in edengrove.
When you get orb which is bind of pick up so you have to craft yourself (you cant buy from AH) just go to edengrove location called Monoecious Cleft where is arena located. Put the orb to the stone and enter arena YOURSELF not with the party. The boss will summon hit him a bit let him kill you and the game automatically teleport you out from arena.
THATS ALL. The bug is gone and you can die now.
I hope it this will help other players who has same problem.
Good Luck and Have Fun.

5 Likes

up

same problem, i will try now

THANKS BRO i fixed it!!!

bumping this

I saw this post a little late and died in the water where I can’t get up.