Stuck at Title Screen

System Information Device name

Processor Intel(R) Core™ i7-7700K CPU @ 4.20GHz 4.20 GHz
Installed RAM 32.0 GB
System type 64-bit operating system, x64-based processor

Any Error messages you are getting. None
What is happening? game loads to title screen.  have verified game files 6 times.  Have reinstalled completely.
Where are you in the process when you run into the trouble? loading game

Hello @mknightsky
I am very sorry you are getting stuck on the title screen.
Since you already verified the files multiple times do you mind doing a hard reset of the computer itself? It might also help to check for windows updates, here is how to Check for Windows updates

To learn more about how to check for Windows updates, go to Microsoft Support.
If the problem persists you might want to do a fresh installation of the game!
Please keep me updated if any of this helps and safe travels! :smiley:

Ok it did do a network update, and some firewall.

I have verified the game files (7 times)
have rebooted now 4 times

still does the same, go to title screen. and stops there

argh war is in 1.5 hours!

ok tried running as Admin, still no go.

I see but did you already try with a hard reset? It might be helpful to disconnect everything and try again.
Maybe even try with a different internet if possible

i also have the same problem, stuck on title screen, i close game, then game still running on task manager

exactly as Nayato stated…

i DID am just now updating nvidia drivers… didn’t notice update… so lets hope this works

Nope updating Nvidia drivers (came out 12/1) did not fix issue

all other games are working,
have hard reset as stated. have checked files 7 times, and have even uninstalled and reinstalled.

have done windows update, updated Nvidia drivers.

have hard rebooted 5 times.

Alright, thank you so much for the update @mknightsky
Let’s go ahead and try some troubleshooting and see if it helps out
1- Press Windows key + R
2- Type %appdata%
3- Go to AppData > Roaming > AGS > New World
4- Delete the Savedata folder and the user_preload_settings.cfg file.
5- Reboot the PC and you’ll see that the files deleted would be recreated.

If not:

-Run a Steam Integrity Check: Steam Support :: Verify Integrity of Game Files

-Reinstall Easy Anti-Cheat: Easy Anti-Cheat

If none of this work or you have already tried the please provide do the following:

  1. Instructions for generating a DXdiag: Open and run DxDiag.exe (Open and run DxDiag.exe )
  2. Instructions for finding the in-game logs:
  3. Press Windows+R on the keyboard, type %appdata% and press enter.
  4. Open the most recent file from this folder: /AppData/local/AGS/LogBackups.
  5. Paste the content on a pastebin using http://pastebin.com/ and share it here.

OK

SO
“1- Press Windows key + R
2- Type %appdata%
3- Go to AppData > Roaming > AGS > New World
4- Delete the Savedata folder and the user_preload_settings.cfg file.
5- Reboot the PC and you’ll see that the files deleted would be recreated.”

worked.

here is the weird thing… noiw when I click game, it OPENS 2 instances of game… first one crashes, then once it times out and crashes it opens itself. AND the second game works.

Weird?

Also I started playing Icarus, did it switch my Direct X to 11 and that could be the issue? As in did Icarus game or could it be forcing Direct X 11 instead of 12?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.