Stuck in character select screen

After today’s patch, my game is stuck in Select Character/Region screen
Tried reinstalling the game/nvidia drivers, verified integrity of files, rebooted, steam updated. /ADD :(EAC reverified/uninstalled reinstalled, steam reinstalled, firewall disabled/enabled, vc++ redistributable reinstalled, changed network connection from LAN to Wifi)
can someone help?

Same thing happens in view worlds screen

The buttons support/settings/quit aren’t working either. I can however go back and forth main menu.

I’m having the same issue. Tried the same things, no go. Haven’t been able to play for a couple of days due to work and wanted to play tonight. TT

The timing is especially bad, since the weekend has just begun. I am not sure whats happening
Either I was banned? (I can’t find any reason other than maybe mass reporting of guild from last war)
or network isn’t proper (tried a different network/vpn as well)

Found this on another new thread:

  1. Restart your computer and launch Steam
  2. Next, you can either right click the game in your Library, or click the gear icon from the game’s Library page on the far right
  3. From the drop down menu, select Properties…
  4. Select the Local Files tab and click the Verify integrity of game files…button

It worked for the person who posted the problem, I’m trying it now.

That was the first thing I tried.

I haven’t played since… Tuesday? And I’ve done nothing to get banned. I don’t even pvp, lol. We’ll see if this works for me. I had already just restarted my PC to update Malwarebytes, then relaunched Steam, so I skipped that step. If it doesn’t solve it, I’ll try restarting again.

I found the fix from this thread

go to %appdata%, for me its C:\Users<myusername>\AppData\Roaming
go inside folder AGS\New World
move the folder savedata any other place and rename it.
Restart the game, fixes this nonsense.

Doing the one I pasted fixed it for me. I’m in, or will be. But, my US West server is scheduled for merging, one says it’s merging with a european server. ::sigh::

Glad you got yours fixed!

Hello, @Xixierra and @ligma1.

I’m sorry that you were facing this issue earlier today.

I’m glad that you were able to find a workaround and got it fixed.

However, I’ll keep an eye on this specific issue and escalate it accordingly.

Have a great weekend and happy holidays!

Having the same issue.

US West, Ophir

I was able to play fine a couple of hours ago.
This has never happened to me before.

Edit: also on the loading screen, none of the buttons (Support, Settings, Quit) work. Very strange

1 Like

This didn’t work for me. It simply reset all the settings and after accepting TOS again, it goes back to not loading any characters.

Hey @batomaru,

I’m sorry that you too are facing this issue.

Would you please visit this page and check maybe, if your server is up for merge?
(the timings mentioned are displayed in your local timezone)

Yes it is. But as I understand from that page, it’s scheduled for December 21st. The downtime to prepare for merge was completed 10 hours ago.


Here’s what I confirmed:

  • deleting savedata in user directory allows me to get to world select page, which is stuck but selecting any other region and then going back to US West and escaping brings me back to my character. By the way, whoever designed world select UI should be beaten with a stick, repeatedly.

  • This allows me to login but after I leave the game, I’m back to being stuck without a character and I have to do the same thing all over again.


This is still an issue and it’s pretty aggravating. Every time I want to login I need to delete savedata folder, which resets all settings and redo them. This is the only way to see my character in game.

Additionally, speech to text is inexplicably turned on each time.

Any word on when can we expect this to be fixed?

good call thank you Ligma1! Not sure if it’s related but I had turned off the sending of Telemetry earlier today and then when I tried to log back in I would get stuck at the character selection screen. If it is related that setting got reset after deleting the folder and I could log in again.

Having same issues. Just deleted steam all together and redownloading steam and New World.

Still having the same issue after deleting game and reinstalling…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.