Stuck in moutain

  • What is your character name in New World: Lajcior2113
  • What server/world did you experience your issue on: Sanor
  • Describe the issue you are experiencing: I’m bugged in mountain and can’t unlock my character
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: I can’t play bcs i’m stucked
  • (if a bug) Were you able to recover from the issue: Nope
  • What are the steps to reproduce the issue as you experienced: I used unlock option 30 times and relogging
1 Like

I’m in the same situation than Kulmobito, I hope that using teleportation will work

I am also currently stuck in a mountain. The Unstuck option simply moves me further into the mountain. I’ve tried relogging once, and I am still trapped. No one can see me apparently, and I don’t know what to do :frowning:

Have you tried Recall to Inn?

I had the same problem. Unstuck didn’t work. Recalling to inn was the only option (which did work).

I did wind up having to do that, but I shouldn’t have too :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.