Stuck on New World loading screen

When I launch new world my cursor starts to load and eventually stops. Then it just remains in the New World background Screen forever. I have tried to verify files, re-installing game, localizations on files and full screen optimization I still can’t get pass the loading screen. Looking for any others fixes to attempt.

Hello Shadowdragon, I’m sorry to hear that your game is stuck in the loading screen for confirmation does your game eventually crashes? Have you check task manager for CPU and GPU usage?

We can try the following:

At that point if the issue persists you might uninstall the game. Delete the following folders and reinstall the game.

  • C:\Users(your comp name)\AppData\Local\AGS
  • C:\Users(your comp name)\AppData\Roaming\AGS
1 Like

The game doesn’t crash just stays in the new world loading screen. I have tried and checked those recommendations already. Except for the last part what would be lost if I delete those files?

By deleting the files you wont loose any game progress or the like but your end game settings.

This is happening to me as well. Reinstalling didn’t do anything. Sad :frowning:

Any news? This just happened to me, I am reinstalling the game but I really dont expect that to fix it.

NVIDIA just put out new drivers today. Was having the same issue but updating drivers fixed it for me.

1 Like

I am having this issue as well after 70ish hours of it working fine.
My PC exceeds the requirements (amd ryzen7 3700, win 11, nvidia 2070, direct x 12, plenty of disk space, and broadband), I have run the Steam verification, my Nvidia drivers are up to date (496.76), Windows is up to date (latest kb5007262 as of this morning).
Did a clean boot by disabling unnecessary services at startup per the instruction above.
Uninstalled and reinstalled the game, with folder deletion, per the instruction above.
Have uninstalled and reinstalled Easy anti-cheat.
None of this has worked.
What else is there to be done just to play the game?

Having the same issue here, over 223 hours played and this bug keeps restricting me from playing the game I acctually enjot despire all the issues. Have tried every fix imaginable. Just looking to play the game.

Anything? @Zweihander

Same issue here, troubleshooted everything

Try using a VPN, doesn’t need to be to another country or anything. Some times the routes from your computer to AWS doesn’t like the traffic for one of many reasons, a VPN will fix that. I had this exact problem and using a VPN fixed the issue.

Also, their servers are currently in maintenance. This likely includes the authentication server which is what causes the issue you are describing in the first place. The game tries to do authentication checks when it launches and can’t reach the servers, so it just sits there. Eventually, if you wait long enough, you’ll get an error saying as much.

After 720 hours, I just got this bug with the winter event patch. Tried everything except a full system reset. Anyone running windows 11? Should I try my luck upgrading?

uninstalled deleted user app data local and roaming folders and updated to most recent NVidia drivers seems to have resolved the problem…

No luck

I recently started to have launching problems as well.

My problem ended up being Norton smart firewall. The exceptions are in there, but for some reason will not let the launcher communicate properly. If I disable smart firewall game launches with no problem at all.

Hopefully this helps you.

Cannot get past new world logo load screen since winter update:

  • System exceeds recommended requirments
  • Steam File verified
  • Updtaed AMD CPU chip set and NVIDIA GPU
  • Updated Windos 10

Deleted below files and re-installed game

  • C:\Users(your comp name)\AppData\Local\AGS
  • C:\Users(your comp name)\AppData\Roaming\AGS

Also have no firewalls. Please advise @Zweihander ?

Recovered windows and re-installed steam/new world, working now.

Got the same issue. I followed alle the the tips&tricks. My Game still stuck in the “new world loading screen” since the winterupdate.

Deleted both appdate folders. Reinstalled the game.
Now this:

EDIT: Just found a workaround! Noticed that only analytics_uuid file created in %appdata% folder after deleting. So i thought it could be a connection Problem not downloading files.

IT IS! Turn off your firewall and voila! Turn it on. Games crashes . :smiley:

Soooo AGS. What did you change? Give us some PORTS please!

EDIT2: Nooope, not a fireall Problem. Now after deletion it works with Firewall enabled.
But: Seems to be a connection issue with new world infrastructure.

EDIT: Sometimes im able to log in and then the game crashes:
<2021-12-18 14:37:49.935>: [Info]: Failed to get shader for sort val: 8640303807
<2021-12-18 14:37:49.939>: [Info]: Failed to get shader for sort val: 8640303807
<2021-12-18 14:38:01.077>: [Info]: Failed to get shader for sort val: 4245311