Stuck Searching for Worlds?

  • What is your character name in New World: Bulldog Briscoe
  • What server/world did you experience your issue on: Opona (menu)
  • Describe the issue you are experiencing: Hitting continue on the main menu results in my character list loading but never appearing. Selecting 'View Worlds" results in a ‘Searching for Worlds’ message without any loading.
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: I can’t log into the game. Tried quitting and relaunching as well as restarting PC. Logging in did work for the first day of the patch but now it’s not.
1 Like

Same. It doesn’t load on my pc, but it does on my friend’s pc.

Update: After restarting the game and my pc, also tried verifying the integrity of files and reinstalling the game. No luck yet

Same issue for me. Tried everything bran_honey mentioned as well. I was told to wait for the server merger to be completed on my server. It’s completed now, and I still have the same issue as I had before the server merge. Also, the main menu is frozen - can’t click settings or the power symbol to quit out of the game.

Update pt. 2: my server merge is supposed to be complete. After updating, restarting, and booting up the game I got stuck on exactly the same character select screen.

This time, however, my fan started making a loud whirring/almost grinding noise on the character select screen. I’m as excited for server merges as the next guy but I think I’m going to put the game aside for a few days until I’m more sure that I’m not about to brick my PC by trying to cut down a virtual tree.

I was also unable to select both settings and quit, I had to close out my game through the steam library

Having the same issue. I even tried deleting the game and redownloading and it still it not working.

Having the same issue. Tried disabling firewall, verifying game file, reinstalling the game, port forwarding, updating graphic card driver and window. No luck.

You are now connected to Prajakta from

Me [11:29:20 PM] : Issue: New World - Technical: Something Else

Prajakta [11:29:21 PM] : Hello, my name is Prajakta. I’m here to help you today.

Me [11:30:49 PM] : Hello my name is I have run into an issue on New World where when I load the game it gets to the character screen but it does not show my character or even the load the worlds from any of the servers.

Prajakta [11:31:40 PM] : Which region/world/server are trying for?

Me [11:32:52 PM] : My server adlivun got merged I think into Frislandia

Prajakta [11:33:51 PM] : Allow me few minutes here. Let me check once.

Me [11:33:58 PM] : Thank you

Prajakta [11:41:07 PM] : Please stay online

Prajakta [11:42:32 PM] : Go through the below post once

Prajakta [11:42:34 PM] :…(See full link)

Prajakta [11:43:54 PM] : All server merges were completed as of 2021-12-21 02:00:00Z (UTC).

Prajakta [11:44:31 PM] : Try uninstalling and reinstalling the game once

Prajakta [11:44:39 PM] : Also try below once:

Prajakta [11:44:57 PM] : -Run Steam and New world as admin

Prajakta [11:44:57 PM] : -Run Integrity check-

Prajakta [11:44:57 PM] :…(See full link)

Prajakta [11:44:57 PM] : -And relaunch the game

Me [11:45:40 PM] : Ok I will try these things

Prajakta [11:45:44 PM] : Sure

Prajakta [11:46:32 PM] : If you still face an issue, please submit a game feedback on below link:

Prajakta [11:46:32 PM] : Game Feedback - New World Forums

Prajakta [11:46:44 PM] : So the developers will look into it.

Me [11:47:04 PM] : Ok thank you.

Prajakta [11:47:15 PM] : Most welcome :slight_smile:

Just posting this to let developers know that I followed instructions and it is still not allowing me to load my character.

Exact same story for me. Character select won’t load, search for worlds is just an infinite spinning ring, cannot even select the “support”, “settings” or “quit” buttons at the top. Fan starts racing as soon as it gets to this point. Restarting game, steam, and pc didn’t help. Reinstalled game, checked integrity of files. No change.

I had this exact same issue. To fix it, I opened Windows explorer and went to this folder and deleted the two mentioned things. One is a folder (savedata) and the other is a file:

  • C:\Users<USERNAME>\AppData\Roaming\AGS\New World (Delete the savedata and user_preload_settings)

It took a series of steps to determine this was the issue. After these files are deleted when starting up the game there are a few things to click on such as the code of conduct, etc. The important thing is that I could login without spinning in world search.

Note that all of the keybinds and some settings remained the way they were and I didn’t have to redo them. But some Visuals and Gameplay settings I did have to correct to the way I had them.

None of the other steps mentioned in any posts prior such as from Prajakta worked.

By the way, how I got into this problem to begin with was that I logged into the game and at the character select screen looking at my character. But I didn’t select the character, I left for about 15 to 30 minutes and when I returned I tried to go from the US-West region to the US-East region. Both of the worlds that I played on were merged to a new world. Once I tried to go to the US-East region was when the endless spinning started happening. The issue was tied directly to the PC not the account as several steps to attempt to resolve the issue pointed to the PC.

Wow just tried and this worked! Thank you so much for your help

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.