Taxes not aplying correctly And repairing Crazy Prices

I’ve had this once. It was whilst paying the tax whilst in a different region where I didn’t have a discount.

Thats my 1º house. So its not only not applying discount for been 1º house but not even applying the discount of my 28% houses discount… Economy is a mess and things are getting worst with each week that comes… And still no outputrush…

Tax discount is not permanent. If you pay taxes at the house the territory bonus should be applied but I noticed if you pay remotely it isn’t.

Also the company who owns your territory is charging an arm and a leg in taxes. I’d not pay it just in protest.

You are right on that. They just conquered the town. But wanyway, the 28% just isnt working. 2400 tax. WIth the economy we have, the crafting and prices how they work and the repair system. Its better to not even play until is fixed to dont be losing money.

Dying at 60 is way way way more easy than dying at low lvl. And repair prices pon tier 5 weapons are madness.

If you go to your house and pay it should be applied

It didnt. Its why I opened this thread. Is not working. Last week it did. Even if it showed a number in the tax and then it was diferent after comparing it with my money left in my bag. Today anything worked as intended.

I guess what I’m asking is are you physically walking to your house to pay the tax or trying to pay it remotely? One works and the other doesn’t

The first house discount only applies to first tax payment after that it’s full pop.

I have no idea about territory discounts from standing. It may not apply if you go past due on your taxes which if that’s a thing I like it.

Yeah the coin costs are really high for repairing while the repair parts haven’t been an issue no matter how egregious the destruction.


The stuff in your bags gets damaged when you die because people were taking all their gear off and suiciding as a way of fast porting back to town and this was the answer… now all your stuff equipped or not get damaged when you die.

Known Issue.

The first buyers tax discount was removed in the last patch:

  • Fixed a housing UI issue. The UI will now correctly shows that property taxes are subject to the full price of the home, and not impacted by the first time home buyer discount.
1 Like

Hmm my tax discount works. T3 house at 5% tax rate = 750g base. I just paid 530g today.

I’m hoping that’s one their stealth fixes (great communication again AGS!). I paid mine on Tuesday, and paid the full 2k for a T4 House.

I am rank 53 in Windward, reduced taxes each chance. Bought my house for 5k and the first tax bill is due for 863 gold…

You’d have to list what the tax rate and your currently available discounts are for us to know if yours are getting applied.

That said, the fact that yours is an uneven # (863g) leads me to believe some % discount is getting applied.

Hoping this will impact my next rent due.

Pointless info if you don’t add the towns tax rate.

If you bought a T2 house (first buy 5k, but taxed as 10k), and the tax rate is 10% it would be 1000 gold. Then with discount it just be the amount you correctly need to pay.

Mine was correct from the beginning. I am 100% sure of that.

In any case I think they should tone down those sliders for the companies.
5 to 20% is way too much leverage, same for all the other taxes. It should be 5% (low), 7.5% (medium) and 10% (high).

I am lucky that the companies owning Everfall and Windsward set the tax rate to low.

1 Like

I payed remotely. But the first time I payed was remotely also.

The first time you probably got your first house discount.

Now it’s bugged and won’t apply your territory bonus.

If you go to your house the discount will apply. I think it’s a known issue as others have said

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.