The First Thing I Remember (Restless Shore Quest)

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: FunkyString
  • What server/world did you experience your issue on: Lethe
  • Describe the issue you are experiencing: I started the quest and retrieved the item, then when I had to talk with Santiago the NPC wasn’t there, I thought it was just a bug so I logged out and reconnect, still wasn’t there. I abandoned the quest to do it again. Now I have the quest marker but still no NPC anywhere.
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: the quest can’t be started again or finished. I love to finish all the quest of a game to complete it, but it’s impossible now.
  • (if a bug) Were you able to recover from the issue: no
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: Start quest, retrieve item, logout and log in, abandon the quest.

Same thing happened to me… got the quest, got the journal, can’t find him… abandon the quest, now there is no NPC quest giver there just barrels… very annoying for a holiday update.

I’ve attached images.

Server is Olympus.

Please fix, thank you.


It’s on a beach just a bit north-west from the town

It doesn’t show on the map, but it’s there and you can safely talk to him and continue the quest

I don’t even have the quest anymore because I abandon it… I cannot pick up the quest again because the NPC is not there… but the quest pickup location shows in the map… when I get there all I see is barrels

Same here, the quest triggers the first NPC to go invisible after obtaining the item but doesn’t show a quest marker for the NPC north of the settlement, so sadly when you abandon the quest during this point it means the first NPC will remain invisible and there is no way to restart the quest currently, the NPC north of the settlement also doesn’t offer the follow-up quest at this point which makes sense because you need to re-do the first part first … such a massive oversight on AGS their part … WHEN YOU MAKE AN NPC INVISIBLE DURING A QUEST STEP MAKE SURE TO MAKE IT VISIBLE AGAIN WHEN PEOPLE ABANDON THE QUEST!

1 Like

this is STILL BUGGED after the 1.2.1. update…

Yep, super annoying.

Another quest bugged…Just picked this quest up today on Xmas eve. Unable to complete. same issues as the posts above.

May I ask something please…Who Tests these quests before release? Nobody, I think. Looks good on paper lets add it!

Can see very clearly our time spent in the game chasing broken quests means nothing.

If you haven’t abandoned the quest yet you should find him at the beach north of the town. i had the same problem but did in fact search for a solution before abandoning and could do the questline without further bugs.

if you have abandoned the quest then you are out of luck… waiting on them to fix it.

Olympus server went down just now… went into maintance without notifiction… maybe they are fixing it? Fingers crossed*

Olympus server went down yesterday, had a maintance but all the bugs are still there.

Nothing fixed yet.

Still cannot pick up quest after abandoned… please fix, thank you.

I’m the same … I hope they solve it soon … I have the mission blocked after abandoning it because I could not find the NPC to complete it :frowning:


I completed the quest requirements, he disapeared even though the marker still shows him in original location. I found him nw of Restless, but he still reacts like I need to find the notes at the second ship and I did read them and kill the crew and I did not abandon the quest at any point. So it is still bugged.

New updates came out today but the quest is still broken.

Please fix!

Quest is still not fixed… what can we do to get this fixed? Anyone in Amazon Gaming watching these threads?

New update kicked in… issues still not fixed.

(Mar 3 2022)
How is this still not fixed or addressed yet?

This is still bugged as of 1.3.2. You still cannot pick up the quest if you previously abandoned it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.