The first thing I remember(Restess Shores quest)

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Jeremiah Scarlet
  • What server/world did you experience your issue on:Valhalla
  • Describe the issue you are experiencing: A new RS quest, the first thing I remember, after retrieving the quest item from Jetsam isle, the quest pointer just dies. No idea where to find the quest npc named Santiago. I tried logging out for a few minutes but he still doesn’t appear anywhere on my map.
  • Is this a bug or an exploit:
  • (if a bug) How did the issue effect your gameplay:
  • (if a bug) Were you able to recover from the issue:
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:
3 Likes

image

I had to Google it but he is outside the northern part of the settlement. When you get close you will see a greyed out quest market but you can talk to him and continue the quest and the quest markers will show up again.

11 Likes

Yep, had to do the same, ty for posting this though.

Same issue here. Thank you for posting this.

I didn’t realize he was somewhere else, and I abandoned the quest. Now he’s in the location listed above, but I can’t restart the quest from the original spot.

2 Likes

Same thing happened to me, there are 2 barrels stacked on top of each other in his original location…

ye same here. Lame, and there’s another quest in cutlass keys called ‘Sea Dreams’ and it’s been bugged for months

Sea Dreams is actually fixed now, so is sweet secrets.

Had this same issue, marker needs fixed

thanks for this post. I’m so done with these kind of bugs. wasted over an hour to find where he was. relogging several times, restarting the game over and over. now i finally found him, but the grey marker wasn’t even on the world map. ridiculous bugs. the world map has been bugged ever since the game has started. Time for amazon to take a serious look into the bugs on the map because it’s really disturbing

This only works when you didn’t abandon the quest after obtaining the item, if you did the first NPC remains invisible and thus you are unable to restart the quest.

i didn’t abandon anything and just followed the quest there shouldn’t be any ‘tricks’ to keep the quest alive or to finish the quest. These are just ridiculous bugs that are in the game since the ever beginning and they release new quests and the same shitshow starts over again. I wonder if they even do test whatever they release or try to release first.

Yes but I (and many others based on threads similar like this) did abandon the quest during this point because I’ve assumed the follow-up quest didn’t trigger, so your solution isn’t working for some of us (as we need to restart the quest from the first NPC which now has turned invisible)

the best solution should be releasing quests without making them bug, it seems to be one of the hardest things so far for the game developers. to have working quests without bugs

same for me, I abandoned the quest thinking it was bugged out because it did not tell me where to go. Who would have guessed that abandoning the quest would permanently bug it?

Same for me as well… Normal procedure for any other game would be to abandon and re-accept the quest, but apparently in this game you’re just supposed to hang on to bugged quests. At least that’s the way it seems since this has happened to me twice now.

Yep, I got hit with this bug as well. Now can’t start/complete the quest.

Hi!

I got same issue! I did the Q and had to turn in the Q and the Santiago guy wasn’t there anymore an empty road… so I abandon the Q and tried to take it again and now I see like the others two barrels on top of each other and can’t take the Q again …

//
RoRo89
Midgard Server

1 Like

me too. i dropped the quest and then quest start marker shows on map but nothing is actually there. I have later found Santiago Salazer in another location but does nothing when I talk with him.

1 Like

I have the same issue. The NPC Santiago is missing. The Quest: The First Thing I remember.
Quest Description: Tell Santiago what you have discovered.

1 Like