The second floor does not work

Character name - Natyral

Server Central Europe Abaton

I bought housing in Everfall for 15k, in the center of the red house. The dwelling itself is two floors, on the first I can put furniture, but on the second I cannot. Everything that I try to put on the second floor shows everything on the first. And so for a week.

Hello ssidoruk5 Welcome to our New World Forum!

I am sorry about this inconvenience, could you please tell me if you have tried any of the known troubleshootings? such as running an integrity check on the game on steam?

Thanks in advance!

This bug has been reported numerous times since the Winter Festival patch over a month ago. You can find a link to my own report here: Tier 3 Everfall House - Cannot interact with furniture/trophies on second floor

I’ve been advised by a moderator on these forums that the devs know of and are working on a fix, but this has been going on for over a month like I said. Some players like myself have their trophies locked on the second floor unable to interact with them.

As a crafter, this stalls my progress in the game as I can no longer craft the highest possible GS items which I require for income and to gear myself up or others in the company for that matter.

I’ve pretty much given up at this stage and if this bug isn’t fixed this week, I’m simply uninstalling. I can’t understand how the devs could make such a mistake and not fix it ASAP with a hot fix patch. People can be patient only for so long…

Hello. Yes, I did an integrity check, reinstalled the game, Steam, nothing helped.

I also have this bug, everyone who owns this cursed house has it too. My friends own the same house and also has it. It’s super annoying as I try to upgrade my crafting trophies to max. Please fix this.

Still not fixed after yesterdays patch.

I’d like to say I’m surprised, but that would be a lie.

“All files have been successfully verified”
What to do next? the second floor is still not working

Hello Adventurers!


I am sorry to know that the previously mentioned troubleshooting step did not work for you.

To further escalate this, I would request you to please contact our live mediums so that they can create individual tickets to the Dev team and help you with a resolution.

You can contact our live mediums by following the below link:

Thank you for your patience & understanding.


The devs know about this issue and it can only be fixed by them. There’s nothing the player can do to fix this bugged house.

To the players experiencing this problem, give up! If you have the money, sell this house and buy another because there’s no telling when these incompetent devs will deem it important enough to fix. If you’re a crafter like me and have had your progress stalled because all your trophies are locked on the second floor of this house in Everfall, this is your only course of action.

This bug has been plaguing my game since the December Winter Festival patch and at best it may be fixed in the ‘big’ bug/balance patch in February. Late February would be my guess.

These replies from CMs saying to lodge a ticket are a slap in the face.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.