Tier 3 Everfall House - Cannot interact with furniture/trophies on second floor

  • What is your character name in New World:
    Bob Gnarly

  • What server/world did you experience your issue on:

  • Describe the issue you are experiencing:
    My tier 3 (two story red house) house in Everfall is bugged. I can place, move and pick up furniture on the first floor, however nothing on the second floor can be interacted with. I’m guessing this is an issue brought on by the latest patch, because I previously placed furniture and trophies on this floor without issue. This is a real concern for me now as I want to do some crafting, but am unable to swap in the relevant trophies meaning my crafted gear will not be rolling as high as it should.

  • Is this a bug or an exploit:

  • (if a bug) How did the issue effect your gameplay:
    I’m unable to interact with my trophies (or furniture) which are located on the second floor of the house. As a crafter, this impacts my crafting gear score.

  • (if a bug) Were you able to recover from the issue:

  • What are the steps to reproduce the issue as you experienced:
    Entering my house even after a fresh restart will reproduce the issue.


Still not fixed after the 1.21 patch.

having the very same issue.

Yep, same here.

@Centeotl @rayman

Hey guys, any chance you could pass this bug onto the devs?

It’s been an issue ever since the December patch and I can’t craft any high tier armor until it’s fixed.

Please fix this. My trophies are immovable from my 2nd floor everfall red house wall, so I’m stuck with weak minor trophies that I first put up.

1 Like

Well I was expecting a patch this week that would finally fix this problem, but still no word on anything happening this week.

This bug that was introduced over a month ago now has basically stalled my game progress. Without the ability to interact with the trophies in this house, I’m not able to craft. As a crafter, I rely on that income and gearing myself up.

If nothing is done this week to fix this bug that’s been reported now at least 20 times I’ve personally seen here on the forums, then I’m just going to uninstall. I’ve wasted enough of my time on this failure of a game sorry to say.

Rainna Thule
Can’t place or pickup items on the second floor of my house in Everfall. Two story house with the stone stairs in front and the passthrough underneath.
Not able to decorate or upgrade trophies.
Have not been able to recover for over a month

Well another patch (1.2.2) and this bug continues to be ignored.


all my trophies are on the second floor

Hello @Bob_Gnarly ,

Hope you’re doing well.

I just want you to please go through these troubleshooting steps mentioned by our support staff for the same issue.

As said before, please try this and let me know if this helped or not.

Looking forward to your response.

See you soon in Aeternum! :woman_mage: :christmas_tree: :deciduous_tree: :evergreen_tree:

Thanks for the reply.

I tried verifying the game files a month ago and again today, but it has not helped.

I’m certain this is a bug that was introduced with the Winter Festival patch over a month ago. This will need to be patched by the devs, it’s completely out of the players hands.

This has been suggested before to other players and has never fixed this house for anyone as it affects everyone who owns this house. Just fix it asap please. My trophies are up there and I haven’t been able to change them out for over a month now.

Hello @Bob_Gnarly , @MikeDaUnicorn and others,

It’s really sad to see that you all are still facing the house issue even after trying the troubleshooting steps mentioned earlier.

Hence I request you to kindly reach out to our support staff by going to :arrow_forward: New World - Support | Amazon Games :arrow_backward:

Be sure to have your game logs ready in case they ask for them:

Provide the latest 3 logs from: Users\AppData\Local\AGS\New World\LogBackups

Instructions for finding the in-game logs:

  1. Press Windows+R on the keyboard, type %appdata% and press enter.
  2. Open the most recent file from this folder: /AppData/local/AGS/LogBackups.
  3. Paste the contents of the file into your message.

Thank you for your understanding.

Take care and stay safe! :slight_smile:

This problem is not on our end of things…running an integrity check isn’t going to solve a damn thing! This bug was caused by the Winter Convergence update…along with several other issues! Would be really nice if someone who actually knew wtf is going on would respond to this issue!

has any of you guys sent logs to them?

@HAWK_EYES what email should we use to send this info, could you post it over here, please?

No I didn’t bother in the end.

I was told by a mod in another thread that this issue has been passed onto the devs to investigate: Everfall Red 2-story house - cannot place decor on 2nd level - #8 by Centeotl

So it’s sounding like at best, this bug won’t be fixed until the big February balance/bug patch.

Some parting advice to the devs.

If you break the game for a chunk of players (ie. anyone that owns this house), don’t take 2 months to fix your fuck up. That is how you lose customers.

Good luck with your game.

Hello @Tom5 as said by @Bob_Gnarly we have already passed the information to our devs to check and in case you want to send us your log files you can send us at cs-reply@amazon.com but only after you were asked by any of our Support Staff at New World - Support | Amazon Games

Hope it helps!!

Thank You for your patience and if you have any doubts you can always reach out to us anytime you want!! :melting_face: :melting_face::

See you in Aeternum!! :magic_wand: