Town Project Pin bugged in Brightwood

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Jocoby

  • What server/world did you experience your issue on: US East/Amsvartnir

  • Describe the issue you are experiencing: When I try to “view in map” a town project for Brightwood that requires I “Search chests for Rivets at The Walsh Congregation” the pin for the quest is at the bottom left corner of the map, off the map entirely.

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: Quality of life, haven’t tried to find where that is on map yet on my own.

  • (if a bug) Were you able to recover from the issue: I’ll look for it or google it

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: I accepted a town project mission in Brightwood from the town project board and the map pin indicator is bugged for that mission.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.