Town taxes not being deposited

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Abes McMuffin
    Town: Windsward - Company: The Bronze Gulls

  • What server/world did you experience your issue on:Deipnias

  • Describe the issue you are experiencing: Town taxes are not being deposited into company treasury

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: Company is broke lol

  • (if a bug) Were you able to recover from the issue: No

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced:

What’s the typical turnaround time for issues such as this? I’ve seen several other players with this issue.

Issue still not resolved

1 Like

Have had the same issue, for 3 weeks now, No Taxes deposited and Thought it was a Thief stealing it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.