Town Upgrades Bugged after server crash in Empi

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Luck2Me

  • What server/world did you experience your issue on: Empi

  • Describe the issue you are experiencing: When server crashed for EVERYONE and came back online I tried starting a upgrade in our town and it ate the gold. Also we had a invasion scheduled and because of the crash we lost 4 tiers.

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: Our company lost 10k gold because of it.

  • (if a bug) Were you able to recover from the issue: No, we are now out 10k gold.

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:


  • What are the steps to reproduce the issue as you experienced: If I try to upgrade it will eat gold again. Please at least throw it back in the treasury. Or revert the town so we can do the invasion instead of losing 4 tiers because of issues on Amazon’s end.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.