Tracking the Huntress - Crafting bug

  • What is your character name in New World: RyderHdz
  • What server/world did you experience your issue on: Lanka
  • Describe the issue you are experiencing:The bow has been crafted but the mission does not take it as finished
  • Is this a bug?: Yes
  • (if a bug) How did the issue affect your gameplay: Can’t complete the quest.
  • (if a bug) Were you able to recover from the issue: No
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: Collect the materials and then create the bow in the workshop, twice after re-establishing the mission (thinking that this would be fixed)
  • When did this happen? 10/25/22 @ 12:30PM BRT

Same issue.
25/10/2022

Collected materials. Went to the engineering station and crafted the bow.
Quest doesn’t give me credit for crafting the bow.

I tried resetting the quest and completing again, same issue.

This is a known issue that is being worked on.

I can confirm this bug. Also crafted the bow an it wont update.

Thanks for that link Jakel.

me too the same happened to me :frowning:

Same issue here, 10/29/22, player name: Lykah on El Dorado server.

What do we do?

Happening to me as well (10/29/22)… dustrho on US East Castle of Steel.

This quest will be fixed tonight after the update: New World Update 1.7.1 - News | New World - Open World MMO PC Game

Nope. I see the yellow icon on the bow in my inventory now. But it appears the quest has reset. It wants me to go fetch all the parts again. There doesn’t appear to be a way to turn in.

The quest itself should be working, but you may have to recraft the bow or reset the quest.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.