Trade legendary gear

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Gosnava

  • What server/world did you experience your issue on: Bensalem

  • Describe the issue you are experiencing: Crafted legendary gear set and can’t complete the trade!!!

  • Is this a bug or an exploit: BUG

  • (if a bug) How did the issue effect your gameplay: Can’t aquire the gear set i grind MANY HOURS for!

  • (if a bug) Were you able to recover from the issue: NO

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: he crafted the gear… we initiate trade… he put gear in trade… we both confirm and the trade never happens!!

same hapened to mee , we both relog and let some time pass and after few tries worked

There is an 8 hour timer on trading voidbent gear, it is (90% of the time) possible to circumvent this by locking the item, unlocking it, then rebooting the game.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.