Trophies Disappeared after Trade

Hello, I was having a friend upgrade 3 ancient trophies and 3 angry earth trophies to Basic. The 3 basic ancient trophies disappeared after the trade was confirmed. Can I get them replaced please? :(.

  • Character Name - Frostypants
  • Issue that occurred - Basic Ancient Combat Trophy disappeared after trade
  • Time and Date - 11/8/2021 ~2-4PM EST
  • World/Server - Uku Pacha
  • Location where issue occurred - Windsward (near engineering bench on bridge)
  • Any steps that can be taken to reproduce the issue - Trade back Basic Ancient Combat Trophies.

Greetings @Frostypants.

Sorry to hear that you are facing this issues with this trophy who appears to be gone.

So I would like to know better the issue, when you went to the trading post and submit the items, they just disappear? And you didn’t get the money or so? Is this the issue that you are facing?

:cat: :octopus:

1 Like

I just has this same issue.

Traded for a Basic Corrupted Combat Trophy and Basic Ancient Combat Trophy.

I the trade itself showed the 2 items but when i got to my house literally 3 seconds later the Ancient Combat Trophy no longer existed. It is in neither of our inventories. The Corrupted Trophy traded just fine.

Duguang- AncientMythos

It was not with the marketplace, it was with a face-to-face trade. The trade back to me showed 3 basic angry earth combat trophies and 3 basic ancients combat trophies. When confirmed, only the 3 angry earth trophies showed in my inventory, and the 3 ancients were gone.

Check this Bug: Basic Ancient Trophy is disappearing on trade (Video link attached)
This bug is over month old…

Greetings @Frostypants , Thank you very much for the clarification.

I will make sure to escalate a case about this, I also take a look and see the other people reporting this as well through this post.
And thank you @Redrick I was able to check the video and we have a visual proof of this issue.

As soon as I get more updates on the ticket I will keep you informed. And once again, sorry about any inconvenience this might cause.

See you in Aeternum

:cat: :octopus:

Just tried the trade again today with 1 Basic Ancient trophy and it worked. Seems to be fixed.

Hello @Frostypants

Thank you for confirming that your issue is fixed.

Please do let us know if you have any other issues.

I will close this thread now.

Happy holidays and safe travels! :mage: :snowflake: