Unable to bind RMB to aim after accidental unbind

  • What is your character name in New World: Paha
  • What server/world did you experience your issue on: Saena
  • Describe the issue you are experiencing:

I accidentally made the mistake of unbinding my Aim (HOLD) button. Now I cannot rebind RMB there because system level unboundable function “turn character” thing from the start menu is blocking it. I cannot set my weapons aim to right mouse button anymore, which makes playing musket main a bit uncomfortable.

  • Is this a bug or an exploit: Bug very much
  • (if a bug) How did the issue effect your gameplay: Very awkward. No quite as good button for aimin than right mouse button.
  • (if a bug) Were you able to recover from the issue: Nope.

Just unbind the RMB from aim and you’ll likely face the same to reproduce.

2 Likes

Im having this issue too but with my block. I cant block anymore. Same error message.

  • What is your character name in New World: Linaria Cousland
  • What server/world did you experience your issue on: Diranda

have you tried using the reset default option?

I can try but would be a huge pain to go back through and set all the key bindings I set. Not the end of the world though.

I used to weapon ability 3 with RMB .
but in new patch .
I can’t setup that.

So is there anything that is being done about this? I had rmb bound to jump and now it won’t bind? I have to go through a 3rd party app to rebind it. WTF?

2 Likes

If AGS can’t fix it, I’m OUT. xD

You guys can go to %appdata% (C:\Users\ [YourUserName] \AppData\Roaming\AGS) folders where you find AGS and New World saved data. There is a file you can edit “rebindings.xml” and i found my aim/blocks etc. there. There will be 3 locations for the keybind, the basic bind itself and the functions press and release, which I just added “mouse2” into the empty bind. This fixed it for me.

Naturally bug is still a bug, but this way you don’t necessarily need to remove all saved settings.

4 Likes

LUV U Bro. :heart_eyes:

Thank you a lot

This is what shows up when I click on ‘‘rebindings.xml’’ Anyone know what I need to do?

Open it in Notepad

2 Likes

I am trying to remap my RMB to my interact function, would that be possible following this method? If so, what action would I have to change?

I deleted all actions with mouse2 and rebinded it in the game

I would assume it’s possible but I think that file there shows only actions you have rebound to something. So if you try to rebind that action in game first, and it shows in that file, just place appropriate keybinds to those functions. Logic would say that it should work, but if it does not, at worst I reckon you can always reset the settings.

Do you guys not have an issue with alt tabbing with this bug btw? The reason I started messing with the binding in the first place was because when I alt tabbed out and back in, it would hold down my right mouse button (block for me) - clicking the RMB would fix the issue. I also noticed when I tabbed out of the game I had to click RMB again to even have control of my other windows applications. This only seems to be a problem when NW is active.

No such problems here, personally.

Hey, I was hoping you might have a chance to help. I’ve been trying to get this working as I’m unfortunately affected by this bug also.

I used to have Ability 1 or Q set to RMB. I had to unbind to test something and now I’m stuck. I tried editing the files and I can get RMB to work to prepare a spell (get it into the aiming action) but I can’t get it to cast the spell. So essentially I can’t double click RMB to prepare and cast a spell.

Any idea what I could be doing wrong?

image

Unfortunately I can’t speak much to that. I can only deduct what I had infront of me as I am not sure of the total mapping scheme they have for different actions. At worst case if it doesn’t seem like you have appropriate option there available, you could try to unbind it again and see if the file updates and specific locations are empty, and replace those. Or if nothing else works, then possibly delete the file and maybe it recreates the defaults?

Unfortunately I don’t have internal confirmations for these one way or the other. I remember seeing topic somewhere that mentioned some of these files being the one you could remove to reset all your personal settings, or maybe the whole folder. But get a confirmation from one of the devs or community rep for that before executing such action.

2 Likes

Thanks Dude. You’re a legend. I’ve opened up a ticket with support so hopefully, it can get fixed soon as it’s very hard to get out of the muscle memory of double-clicking to cast which now prepares and then unprepares the ability.