Unable to buy house in Windsward

  • What is your character name in New World: notAwitcher
  • What server/world did you experience your issue on: Utopia
  • Describe the issue you are experiencing: I am unable to purchase the white house in Windsward above the Marauder Quest NPC, I have the first house discount so it costs 2.5k and I have level 11 territory Standing, I can click on purchase and it pops up saying I am now A house owner but when I close the box the house is still for sale and I cant enter or recall to the house.
  • Is this a bug or an exploit: Bug.
  • (if a bug) How did the issue effect your gameplay: Cant buy a house.
  • (if a bug) Were you able to recover from the issue: No.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: I didn’t take a picture of this but it is very simple to recreate.
  • What are the steps to reproduce the issue as you experienced: “Buy” A house.

I have this exact same problem. What are we to do?

Same issue with me and other company members. I currently own 2 houses that i bought yesterday shortly after the update, but then later on during the day i went to buy a third house, the T1 house in Brightwood next to townboard and the same thing happened to me. Friends weren’t able to buy T1 houses at windsward, monarch’s bluff, everfall or ebonscale reach as well, all the same with already owning 2 other houses. Havent yet tried buying a T2 or above houses for reasons of not having enough money as you can see below.
Can’t buy a T1 house in Brightwood

any answer on this?

Im having the same issue. I get the House Purchased, Congratulations you are now a home owner screen, but I don’t actually get the house and the money remains in my inventory. Trying to purchase the T1 house in Windsward and I currently own 2 other houses.

Same issue. I already owned a home before I transferred to this server and am trying to buy a T1 home in brightwood. It says House Purchased but I actually don’t get the home. I did notice the coin in the top right said 10,000 coin when i actually have 32,597.84 coin at the time of attempting the purchase. I have also tried in Weaver’s Fen on a T4 house with same results.

After the patch, I still was unable to buy a T1 home in Brightwood but I was able to buy a T2 home and seems to be working. Guess no cheap living for me. But still appears to be some issue with purchasing certain types of homes, can’t try any other levels well because i’m broke now lol

i have same issue too.

Still no fix?

Same issue

Same Issue

Same issue was in Brightwood

still cant buyyyyyyyyyyyy

Same here

I got the same issue

Same issue for me. Unable to purchase the 5k house in Windsward next to the town board. Gutted to see this has been going on since november already.

Exactly the same problem. 5k house in Windsward.

Unable to buy house in windsward too. The 5k one by the boards. Still no fix?

Same here, but my problem is with 5k house on brightwood.

Still have this issue with 5k house in windsward aswell