Unable to complete Monarch’s Edicts quests

The territory story Monarch’s Edicts is stuck at 3/4 quests completed. I have no outstanding quests in monarch’s bluffs. No markers showing on the map, nothing available from Npcs and no quests available in the journal.

Character is Dunnock on a baton.

1 Like

Hello mongo,

I’m sorry you’re having issues with your Monarch’s Edict’s quest.

For this issue you can follow this troubleshooting related with the AGS Files that are linked within New World:

  1. Windows + R type in %APPDATA%
  2. Go to Local and Roaming (Both files will include an AGS file) and open them.
  3. Rename the AGS sub-folder ‘‘New World’’ to something different like ‘’_New World"
  4. This will refresh the cache files within New World and remove the error launching the game.

Please let us know as soon as possible if after these troubleshooting the problem persist.

Thanks for all your feedback and specially your patience. :man_mage: :small_blue_diamond:

Screenshot 2022-04-14 5.56.31 AM

Hi Cactacea, that worked !

Thank you very much.:+1:

1 Like

I’m really happy to hear it worked for you mongo,

Thank you so much for sharing you were able to fixed it and I wish you safe travels in Aeternum. :world_map:

Screenshot 2022-04-14 5.56.31 AM

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.