Unable to Complete Quest: Trial of the Cabalist. Quest broken and unable to advance faction levels! 02/11/2021

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Gapsoo
  • What server/world did you experience your issue on: AP SouthEast Erythia
  • Describe the issue you are experiencing: On the quest Trial of the Cabalist I am asked to place Psychokinetic Absorbers in different areas. The last area “Sorrowsilt Ridge” is bugged and when I reach the marker to place the Psychokinetic it is greyed out and does not let me interact with the point of interest. Ive checked my inventory too and I do not have and Psychokinetic Absorbers in there so i dont know what to do. Ive tried relogging and going back to the quest giver and neither have fixed the issue. This is a gamebreaking bug because now I cannot advance to the next level in my Faction quests.
  • Is this a bug or an exploit: BUG
  • (if a bug) How did the issue effect your gameplay: I am completely stuck on my faction quests now.
  • (if a bug) Were you able to recover from the issue: NO PLEASE HELP ME
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
    [Imgur: Imgur: The magic of the Internet
  • What are the steps to reproduce the issue as you experienced: Attempt to complete Trial of the cabalist. After planting Absorbers on the east side of Mourningdale more west to place the Absorber at ‘Sorrowsilt Ridge’. It is greyed out and I cannot interact with it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.