Unable to complete trade for my final Voidbent piece from craftsman

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Rezlind

  • What server/world did you experience your issue on: Themiscyra

  • Describe the issue you are experiencing: I gave the materials for my armorer to craft my voidbent guantlets. They crafted it but are now unable to trade them to me.

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: I am unable to complete my gearset

  • (if a bug) Were you able to recover from the issue: No, they live in australia and we cannot trade again until after I finish working today so super late night.

  • (if a bug) Please include a screenshot or video of the issue that you have experienced: BSkW7GoaiY

  • What are the steps to reproduce the issue as you experienced: We simply tried to trade, the trade would not complete even though it appeared to confirm.

@Luxendra @Kay @TrevzorFTW

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.