Unable to declare war Mourning Dale

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World:
  • What server/world did you experience your issue on:
  • Describe the issue you are experiencing:
  • Is this a bug or an exploit:
  • (if a bug) How did the issue effect your gameplay:
  • (if a bug) Were you able to recover from the issue:
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: My characters name is Badger222 and my company Faceless Order on the Ogygia server have spent the last 2 days pushing Mourning Dale into conflict we got to 100% and now can not declare war. I go to declare and nothing happens. My company worked so hard to do this and now this is the second time this has happened, my whole company is planning to stop PvPing because of this


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.