Unable to fast travel after patch (yes i did tried relogging and didnt work)

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: Billy333
  • What server/world did you experience your issue on: Barri
  • Describe the issue you are experiencing: Unable to fast travel or recall to home with the prompt saying “Fast travel Failed” 3 second or 5 seconds in the fast travel
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: makes my hands shake from the thought of walking 30 mins
  • (if a bug) Were you able to recover from the issue: yes after 10 mins and multiple relogs (but my friend still hasnt)
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: unknown ( i was in a group with 2 people and we were both unable to fast travel at the same time)
  • When did this happen? 15 mins before this (Date and Relative time; please include your timezone)

Same happening to me on Ygg. I was able to fast travel once and haven’t been able to since even after multiple restarts.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.