Unable to play - game crashing

I have had to cntrl/alt/delete to close out the game 4x now because of freezing, I can’t craft anything bc azoth vials are disabled, and I can’t load the game because it gets frozen on the logo screen.

Something to vital to every system of the game, such as azoth, should NOT take nearly a week to fix. What is this, amateur hour?

Get your shit together AGS, I am fed up.

Sounds familiar to my struggle. AGS seems to be focused on what could be wrong with my computer rather than their game. Game Freeze ..... Again - #9 by Susan_Ivanova

Hello @musashie and thank you @Susan_Ivanova for your input,

I am sorry to hear you seem to be getting sporadic freezes.

Here are some basic steps you can try in order to troubleshoot this:

  1. Ensure your video drivers are up to date.
  2. Set Windows power settings to High Performance.
  • Press Windows + R, type “powercfg.cpl” into the Run window, and then press Enter.
  • Select the radio button next to the High performance power plan. You may need to click Show additional plans first.
  1. Adjust your in-game video settings. (sometimes just changing them back and forth will reset the issue)
  2. Clean boot Windows by following these instructions:
    How to perform a clean boot in Windows (to reduce startup applications/Check for Malware).
  3. Reset your video driver software to the default settings.
  4. Check for evidence of overheating.
  5. Please verify the integrity of game with the Steam integrity check
    How To run a Steam Integrity Check

If the issue persists after this, the scenario will require our tech team to look into your logs and follow up directly with other possibly sensitive account information that is best not posted on the forums so it would be best if you could please create a web ticket by going to Contact Us | Amazon Games.

I hope this helps and if not, do not hesitate reaching out to live support.

See you in Aeternum! :wolf:

This is getting tiring…All my video drivers are up to date, there is no evidence of overheating (my fans don’t even kick into high unless I’m online playing some game and my system performs its daily integrity sweep). I have played this game since Alpha and understand how to run a Stem integrity check (in fact my previous posts in the thread I attached above explained that). I played the game for about 2 hours last night without incident (but I did delete the contents of the remains AGS savedata file first). Here is an example of the kind of performance my system reflected.


I will log into the game shortly (without deleting the contents of the aforementioned AGS file) and see just how long it takes the game to freeze. I will think pure thoughts and hope that the scripted ipconfig exercise I was given yesterday did the trick. By the way, I loved the follow up e-mail from Amazon Support regarding my latest Lost Ark game inquiry…can’t even click on the right scripted e-mail to send…smfh

1 Like

You’re not the only one. Personally for me it happens when fast travelling to a new place. The game will just lock up and force me to kill it through task manager. Note though that it doesn’t happen all the time. For example, I just finished fast travelling to every city to claim the summer event reward. No crash.

Teleported back to MD, crashed.

Logged back in, teleported to EF, no issues. Teleported to a Reekwater shrine, crash.

Logged back in, teleported to SM, crash.

It only crashes once the teleport is complete. Sometimes in loading screen, sometimes the moment I load in, sometimes the moment I take a step in the place. Either way, game’s borderline unplayable.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.