Unable to Trade Voidbent with Friend!

  • What is your character name in New World: Wildjaw

  • What server/world did you experience your issue on:Eden

  • Describe the issue you are experiencing: Crafted Voidbent for a buddy and tried to give it to him. At first we couldn’t do it, it was just saying ‘something went wrong’ when we traded. I ended up trying piece by piece and was able to trade him the gloves. But the boots and the hat would not trade. Also, when I was crafting the boots and the hat the labels were wrong on the UI menu (didn’t think much of it). So we tried to get creative and get him the voidbent by putting the items on a dead market (north of edengrove) and he would by them off the post really quickly. But that didn’t work either. When I would try to place a sell order on the voidbent Boots or Hat it would say ‘insufficient items’. So in conclusion, the items I’ve spent 40+ hours gathering and crafting are non-existent and useless. And I can’t even gift them to a friend. Please help fix this.

  • Is this a bug or an exploit: Bug / Don’t see how it could be exploited but who knows

  • (if a bug) How did the issue effect your gameplay: Completely ruined a huge part of the game

  • (if a bug) Were you able to recover from the issue: No

  • (if a bug) Please include a screenshot or video of the issue that you have experienced: image

  • What are the steps to reproduce the issue as you experienced: Open trade window - Trade Voidbent Hat or Boots - Confirm Trade OR Try to place a sell order for Voidbent Hat or Gloves

Log out until you have fully completed the logout timer (like 2 mins to be safe). Voila you can trade it. Known bug forever, dont expect a fix before the billion exploits do.

2 Likes

Thanks, will try again!

And if that first part doesn’t work supposedly you have to lock the armor from salvage before logging out, wait fully as they said, and then unlock when logging back in.

1 Like

My friend made me a piece. just send some gold and items in the trade instead of for nothing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.