Unplayable lag help

Yours looks smooth compared to what I’m dealing with. I have massive teleporting and rubberbanding, even though my ping is sub-200 and all graphical settings are low with a capped 60 FPS. I can run anything on max settings normally but this game is choking on itself.

Whatever’s wrong is definitely not on my end.

3 Likes

I played 15h without any problem and today, with no reason my input lag increased massively and stay stuck at 400 ms, everybody was teleporting with the message “lag detected”. I tried latencymon, an online fps and a internet connection test without any problem. Haven’t any other choice than disconnect from the server.

Yeah, that’s why I’m hoping a tech guy can come help because my computer is not the problem, at least not to my knowledge, becase I don’t have any issues with an other games.

That is what happens to me every single day. I had to get off last night because it was quite literally unplayable.

Same here, didn’t happen in Beta closed and open tests, so what gives now Amazon? The input latency gradually builds to the point where I am lag dying and rubber-banding all over… It is unplayable as is.

Hi @Arcticc

Im sorry for the issue you have. Can you please check the following Troubleshooting Input Lag - Support | Amazon Games and Troubleshooting Lag and Connectivity Issues - Support | Amazon Games.

Also common issues at Welcome to New World!

Thank you so much for your patience during this launch time.

None of that helped :confused:

Very similar issue, coming from Midwest. Can’t get a stable connection on either West or East servers (East being a little better but not much) with constantly climbing/fluctuating input latency. I don’t recall having any issues in Beta (or I wouldn’t have purchased).

High end rig and stable internet that hasn’t had any issues with any other games.

2 Likes

This is exactly the same issue I am having. Midwest gamers getting hosed.

I have the same problem

So I fixed it on my end…ended up rolling back to the previous Nvidia drivers and now I have a stable input latency, roughly 115 on West, 70 on East. Give that a shot if you’ve updated your GPU drivers.

I can’t unfortunately because my computer didn’t remember the past drivers.

I’ve got the exact same issues on the EU servers with an AMD CPU/GPU, so whatever causes this it’s more than just Nvidia drivers or server location.

Yep same here too many times I’ve died and not even know how until the latency stopped going so high. I get in the thousands. And it happens so random

If you are from US and playing on EU servers you are most likely fu*ked and need to change server. The same goes other way around too since the damn big “lake” in between causes issues and Im not totally familiar with this games engine but it sounds like over 200ms ping is a death sentence.

If you are inside your own region and continent (bad wording maybe) and geting insain lags and lag spikes then you should contact your own ISP and ask them do they have blocks/limitters for certain games (that means ports in general) since this isnt anything new that example British players are having hard time playing on french servers.

I can confirm that the lag/latency is a serious issue. Even less than <140ms. I am near the west cost (mountain time) and, to play with friends, rolled on the US-East servers. My connection/latency hovers around 134 and during combat I am often teleporting short distances, rubber banding, and crippling desync when attacking anything. Things I’ve tried that didn’t help:

  1. Configuring my router to use Google DNS
  2. Setting up port forwarding to include the TCP & UDP ports that they list on their help page.
  3. Updating GPU driver, updating router firmware
  4. Reconfiguring my AMD GPU through their software interface
  5. Tried to verify my game files through Steam
  6. Deleted local user temp files
  7. Making manual edits to my registry to disable the Nagel Algorithm (look this up on your own).

Not a single one of these fixed my issue. I don’t have any sort of AWS data center information to run a trace route. I did a ping test from my location to Ohio & Virginia (Where I’m certain the AWD data centers reside and this was <90ms.

Conclusion: This is an issue on New Worlds end and they will have to address.

2 Likes

Is this happening all over the game world or just in dungeons ? since my EU saena server needed a reboot/restart to get me dungeons running properly…

and for my case I have decent 100mb/sec upload 500mb/sec dload connection … and thats not eve the max I could get

all over the world

1 Like

Today I just started experiencing precisely that. I can’t land a single attack. I lagged so much at some point while firing my musket that everything froze in place for a couple of seconds, and when I unfroze my character shot like 20 bullets at once, my eardrums almost went out, lol

Hey, Same here…
Im from germany and playing on a DE/ENG Server. im Rubberbanding all over the world. sometimes 30 seconds to a minute… i tried everything possible. Unlocked Ports, limited my bandwith to erase the bufferbloat. checked every Option in the artical of the official website.
there must be a seriuos problem on the servers.
Please Amazon… that can´t be it?!

1 Like