Verdant Connections Gemstone bug

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: Dragonrodeov2

  • What server/world did you experience your issue on: Sutekh

  • Describe the issue you are experiencing: i have lost the gemstone for Verdant Connections quest i placed it into storage and now it has gone and cannot proceed with the main story line quest

  • Is this a bug? yes

  • (if a bug) How did the issue affect your gameplay: i cannot no longer progress my character on the main story line

  • (if a bug) Were you able to recover from the issue: no im still stuck unable to continue

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: get verdant gemstone place into storage ?

  • When did this happen? (Date and Relative time; please include your timezone) gmt +13 10/11/22 1030

1 Like

I have the same bug. Nitzilla on Heliopolis.

Welcome to the New World forum community, Nitzilla. Thanks for letting us know you’re having this issue as well.

So is there a solution? Seriously. I can’t advance the main questline. I am level 20 and won’t be able to go into dungeons at level 25 if I don’t get the doo-hickey that is the reward for the main quest line. I am doing town quests for now but that will get old quickly.

Kyokuchi on Minotaur.
I have the same bug, I logged in and the gemstone just wasn’t there… not in my inv not in my storage.
It happened today I just realize at 21:00 aprox, gmt -3 I think, 20/11/22

Still nothing. In game or here. Just a generic Thank You for the post. Very discouraging. I was patient when my original post was on a Sunday but now it is two full business days with no meaningful contact. Is this a bug? Did I do something wrong? Can it be reset. Do I have to start a whole new character? (Spoiler alert: I won’t. I’d be done with the game at that point.)

I still feel like I got my forty bucks worth. Seems strange.

Still no response, to OP much less any of my posts. Not looking for a solution at the moment as much as some communication. I consider the game currently unplayable and I really should get some kind of clarification as to how I’m supposed to proceed in the game.

The team is looking into this issue. Unfortunately I have no further updates to provide regarding this one.

Thank you for confirming that the issue is being addressed. If there’s anything I can do to expedite the process let me know. Otherwise if a fix is in let me know that as well and i can dive back in.

Not a problem!