Very low FPS despite very good pc conf

Hello,

I have very low FPS (average of 10 in cities and 25 outside) depite having a quite good pc.
I tried to lower the settings, no changes.

Here is my config :
RTX 3080 (drivers up to date : 472.12)
i7-7700K CPU 4.2Ghz
32 Go RAM
Windows and the game installed on SSDs
DX12

Any idea ?
I can run other demanding games like Cyberpunk, AssassinCreed, etc… no problem

1 Like

Hello @Gribrou

Thank you for the report. Please check the following link Troubleshooting Frame Rate and Performance Issues - Support | Amazon Games and System Issue: 99% GPU Load
Some users may encounter a situation where playing New World will result in the GPU Load reaching 99%. Please give the following steps a try to fix this issue:

  1. Enable V-Sync (Please note that if you have GSYNC/FreeSync enabled, this will affect the refresh rate matching those features utilize).
  • Enabling V-Sync with NVIDIA Control Panel
    Right-click your desktop and click ‘Nvidia Control Panel’.
    Click Manage 3D settings.
    Under ‘I would like to use the following 3D settings’ scroll down until you see Vertical sync.
    Select Vertical sync and choose ‘On’ from the drop down, and then select Apply.
  • Enabling V-Sync with AMD Catalyst Control Center
    Right click your desktop and click AMD Radeon Software (or press ALT+R)
    Click the gear icon found on the top right of the app.
    Click on “Graphics” at the bottom of the left-hand side
    Click on Radeon Enhanced Sync to enable it.
  1. Confirm that you have the latest updates installed for Windows.
  2. Check that you have the most recent drivers installed for your GPU.
    Nvidia Drivers
    AMD Radeon Drivers

Blurry Text/Blurry Visuals in-game
If you find the game blurry or text blurry and adjusting your native resolution does not fix the issue you can try these steps:

  1. Go to “New World” in your Steam Library.
  2. Click Settings.
  3. *Click Manage.
  4. *Browse Local Files.
  5. Right click on NewWorldLauncher and click properties.
  6. Click Compatibility.
  7. Click " Change High DPI Settings ".
  8. This will open a dialogue box - to select (checkbox) " Override high DPI scaling behavior " Make sure for Scaling performed by: “Application” is selected. from Welcome to New World!

Thank you so much for your patience during this launch time.

I’ve been havinig the same issue with the same specs. Not sure if i7-7700k is finally showing its age or it’s an issue with the game, but II have friends with cpus with 6-8 cores getting better frames than me. Changing the settings from very high to low barely changes the the frames i get

Having the same issue but using RTX 3090 on i9-10900k

Check your GPU usage in an app like MSI afterburner.

I am noticing that the GPU usage suddenly drops to around 30-40% in certain areas and that is causing the massive frame rate drops.

Outdoors i am getting around 150FPS but when i go to a town etc it drops to around 30 FPS

@Standor There is a real problem with the GPU usage in New World, it really needs to be looked into

What about populated area like where people farm a boss for a quest? How does your FPS do there?

Perfectly fine in busy areas, it’s only really towns and a few other random areas

Here is a good example of what is happening to me, same as this often in towns.

Yea I’ve had that same issue as well, where looking at a certain angle in some random location tanks FPS. No clue why

**Blurry Text/Blurry Visuals in-game**
If you find the game blurry or text blurry and adjusting your native resolution does not fix the issue you can try these steps:

1. Go to “New World” in your Steam Library.
2. *Click* **Settings.**
3. **Click* **Manage.**
4. *Browse Local Files.
5. *Right click* on **NewWorldLauncher** and *click* **properties.**
6. *Click* **Compatibility.**
7. *Click* " **Change High DPI Settings** ".
8. This will open a dialogue box - to select (checkbox) " **Override high DPI scaling behavior** " Make sure for **Scaling performed by: “Application”** is selected. from [Welcome to New World!](https://forums.newworld.com/t/welcome-to-new-world/96268)

Doesnt work for me((

I dont know what to do… Nvidia 1070ti

Did you ever find a fix?

did you ever find a fix?

Hi, sorry, forgot to update.
In my specific case, it was because of a broken watercooling pump, when my CPU reached 100°C, the security then automatically underclocked it (from 4.4Ghz to 1.3Ghz).
Changed the pump, and I’m all good now.

I am stunned your machine just didn’t restart or the CPU pop.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.