"Walsh Congregation" mission still not fixed

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: Madam Healer
  • What server/world did you experience your issue on: Castle of Steel
  • Describe the issue you are experiencing: Mission is off game map
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Can not complete mission, even going to town where it should be located, it will not update and the distance literally is off the map 100%
  • (if a bug) Were you able to recover from the issue: No
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

    This shows the distance from Brightwood where the mission is at on the town board.

    This is the name of the mission, the one on the bottom
  • What are the steps to reproduce the issue as you experienced:
    This bug has been around since October of last year and no one can still figure out how to fix this bug? Come on guys…really? Just another bug still not fixed and getting ignored?

Getting this looked at! Thank you for your report.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.