Winter Warrior Bugged

What is your character name in New World: Avalean

What server/world did you experience your issue on: EU Aquila

Describe the issue you are experiencing:
Managed to max all of my winter rep, bought all the gear I wanted to include the end rep ice gear.
Completed all the winter warrior quest line up to kill final boss. by level 41 so well below level.

After much work I managed to get to the final location all by myself, Parked my toon and had to wait 2 days for my folks to be working a group in the area so I had support for final boss.
With support we fought our way into the cave, defeating all the support mobs.
I placed the items on the alter and Boss appeared.
I Used my ice staff to range attack while the other 3 lvl60s kept him engaged and off of me, after a bit we killed the boss.
NOW the quest line in my journal shows I found location, shows I used the alter and summoned the boss but will not show I killed him.

  • Is this a bug or an exploit: BUG

  • (if a bug) How did the issue effect your gameplay: Massive let down now may not be able to finish the winter quest lines due to this.

  • (if a bug) Were you able to recover from the issue: NO

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced:
    I Logged off and retried still a no go.

So I tried to totally leave the area, then returned, so we had to kill all the mobs all over.
Got back to alter and it would show the “Use E” interact but would not work.
This took me several hours just to work my way there at my level solo and having this happen is a total slap in the face.

Now I am not certain I will even have time to work my way from WW all the way up there again before the winter event ends. Let alone grab enough folks to help me kill him again as well.
And please do not tell me I have to redo the entire quest line due to this issue.

Could someone please just pop the quest in my account and fix this?

I don’t think you did enough damage on the boss to get credit.

we did the same with the other 2, yet in either case it still will not let me resummon him. As you see in my pack is now the left and right sections PLUS the summoning stone. I had a similar issue with a different quest where you make a sword and turn it in, but no matter how many swords I made would not accept them, had to wait for them to fix the issue.
In “most” MMOs if you damage the target no matter how little or much when in a party you still get credit for helping in the kill.
So just reporting the facts as they currently are is all.
So just waiting for the DEVs to let us know why it is doing this.

It now shows all completed but winter warrior, however the “use 2 halves” section says Optional.
So if I manage to get some to go there before it ends will try to just kill him.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.